Android5.1系统应用移植Android7.1报错

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/weixin_40391500/article/details/79635006

Android5.1 apk移植到Android7.1调用so库失败解决
错误日志:
03-20 18:51:11.075 19704 19704 E linker : library “/system/lib/libserial_portlib.so” (“/system/lib/libserial_portlib.so”) needed or dlopened by “/system/lib/libnativeloader.so” is not accessible for the namespace: [name=”classloader-namespace”, ld_library_paths=”“, default_library_paths=”/system/fake-libs:/data/app/com.icarvisions.icarscreen-2/base.apk!/lib/armeabi-v7a”, permitted_paths=”/data:/mnt/expand:/data/data/com.icarvisions.icarscreen”]
03-20 18:51:11.076 19704 19704 D AndroidRuntime: Shutting down VM
03-20 18:51:11.088 19704 19704 E AndroidRuntime: FATAL EXCEPTION: main
03-20 18:51:11.088 19704 19704 E AndroidRuntime: Process: com.icarvisions.icarscreen, PID: 19704
03-20 18:51:11.088 19704 19704 E AndroidRuntime: java.lang.UnsatisfiedLinkError: dlopen failed: library “/system/lib/libserial_portlib.so” needed or dlopened by “/system/lib/libnativeloader.so” is not accessible for the namespace “classloader-namespace”

解决:
在/system/fake-libs路径下push入相应的so库

猜你喜欢

转载自blog.csdn.net/weixin_40391500/article/details/79635006
0条评论
添加一条新回复