hdu2255 奔小康赚大钱 (带权二分图最佳匹配)(km算法模板题)

Problem Description

传说在遥远的地方有一个非常富裕的村落,有一天,村长决定进行制度改革:重新分配房子。
这可是一件大事,关系到人民的住房问题啊。村里共有n间房间,刚好有n家老百姓,考虑到每家都要有房住(如果有老百姓没房子住的话,容易引起不安定因素),每家必须分配到一间房子且只能得到一间房子。
另一方面,村长和另外的村领导希望得到最大的效益,这样村里的机构才会有钱.由于老百姓都比较富裕,他们都能对每一间房子在他们的经济范围内出一定的价格,比如有3间房子,一家老百姓可以对第一间出10万,对第2间出2万,对第3间出20万.(当然是在他们的经济范围内).现在这个问题就是村领导怎样分配房子才能使收入最大.(村民即使有钱购买一间房子但不一定能买到,要看村领导分配的).

Input

输入数据包含多组测试用例,每组数据的第一行输入n,表示房子的数量(也是老百姓家的数量),接下来有n行,每行n个数表示第i个村名对第j间房出的价格(n<=300)。

Output

请对每组数据输出最大的收入值,每组的输出占一行。

Sample Input

2
100 10
15 23

Sample Output

123

分析:

裸题.

(km算法看的这个人的:hehedad的博客

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
typedef long long ll;
const int inf=0x3f3f3f3f;
const int inn=0x80808080;
using namespace std;
const int maxm=305;
int g[maxm][maxm];//权值
int a[maxm];
int b[maxm];
int amark[maxm];
int bmark[maxm];
int now[maxm];
int need[maxm];
int n;
int dfs(int x){
    amark[x]=1;
    for(int i=1;i<=n;i++){
        if(!bmark[i]){
            int temp=a[x]+b[i]-g[x][i];
            if(temp==0){
                bmark[i]=1;
                if(now[i]==-1||dfs(now[i])){
                    now[i]=x;
                    return 1;
                }
            }else{
                need[i]=min(need[i],temp);
            }
        }
    }
    return 0;
}
int km(){
    memset(now,-1,sizeof now);
    memset(b,0,sizeof b);
    for(int i=1;i<=n;i++){
        a[i]=g[i][1];
        for(int j=2;j<=n;j++){
            a[i]=max(a[i],g[i][j]);
        }
    }
    for(int i=1;i<=n;i++){
        memset(need,inf,sizeof need);
        while(1){
            memset(amark,0,sizeof amark);
            memset(bmark,0,sizeof bmark);
            if(dfs(i))break;
            int d=inf;
            for(int j=1;j<=n;j++){
                if(!bmark[j]){
                    d=min(d,need[j]);
                }
            }
            for(int j=1;j<=n;j++){
                if(amark[j]){
                    a[j]-=d;
                }
                if(bmark[j]){
                    b[j]+=d;
                }else{
                    need[j]-=d;
                }
            }
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++){
        ans+=g[now[i]][i];
    }
    return ans;
}
int main(){
    while(cin>>n){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&g[i][j]);
            }
        }
        cout<<km()<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44178736/article/details/92853688
今日推荐