[ZOJ1003]CRASHING BALLOON(DFS)

Crashing Balloon


Time Limit: 2 Seconds      Memory Limit: 65536 KB


On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she's crashed.  The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge his\her opponent's score.  The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution.

INPUT

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

OUTPUT

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
62

题意:地面上有100个气球 编号为1~100 两个人踩气球 初始分数都是1 踩到相应编号的气球则分数乘以相应编号 最后两个人报出自己的分数 分数高的取胜 但是可能存在有人说谎的情况 分数低的人可以质疑分数高的人 如果分数高的人有一个分数不是自己踩气球得到的 则质疑是对的 分数低的选手是赢家 例如 分数高的选手要得到他说出的分数必须要踩到分数低的选手一定会踩到的气球 则质疑成功  另外 如果两个人分数都计算错误的话 则质疑被否决 

题解:根据题目要求模拟 首先将分数高的赋值n 分数低的赋值m 之后通过递归因式分解 判断是否有公因子 因为气球编号是1~100 所以从100开始向下判断因子就好了 如果有公因子 分数低的选手是赢家 如果没有 分数高的选手是赢家 如果全部说谎或者全部正确 则判断高分获胜 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

bool aT, bT;

void dfs(int n, int m, int p);

int main(){
    int n, m;
    while(scanf("%d%d", &n, &m) != EOF){
        if(n < m){              //将分数高的赋值n 分数低的赋值m
            swap(n, m);
        }

        aT = false;             //先将a b都赋值为说谎
        bT = false;

        dfs(n, m, 100);         //递归因式分解

        if(!aT && bT){          //只有高分的说谎 则输出低分
            printf("%d\n", m);
        }
        else{                   //高分的没有说谎或者全部说谎或者全部正确 则输出高分
            printf("%d\n", n);
        }
    }
    return 0;
}

void dfs(int n, int m, int p){
    if(n == 1 && m == 1){       //两个人都没有说谎 将aT赋值为没有说谎就好了 
        aT = true;
        return ;
    }
    if(m == 1){                 //低分者没有说谎
        bT = true;
    }

    while(p > 1){               //因式分解
        if(n % p == 0){
            dfs(n/p, m, p-1);
        }
        if(m % p == 0){
            dfs(n, m/p, p-1);
        }

        --p;
    }
}

Alpha

猜你喜欢

转载自blog.csdn.net/u012431590/article/details/81871830