题解:Power Strings

题目描述
Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

输入
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出
For each s you should print the largest n such that s = a^n for some string a.

样例输入
abcd
aaaa
ababab
.
样例输出
1
4
3

给出由字串N个A字串构成的字符串,求N最大为多少,
运用next数组;L/(L-next[L])即为所求的值

#include<bits/stdc++.h>
using namespace std;
char s[1000005];
int next[1000005];
void getnext(char *a)
{
 int len=strlen(a);
 int i=0,j=-1;
 next[0]=-1;
 while(i<len)
 {
 	if(j==-1||a[i]==a[j])
 	 next[++i]=++j;
 	else j=next[j];
 }
}
int main()
{
 while(scanf("%s",s)!=EOF&&s[0]!='.')
 {
 	int len=strlen(s);
 	getnext(s);
 	if(len%(len-next[len])==0)
 	 printf("%d\n",len/(len-next[len]));
 	else
 	 printf("1\n");
 }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43540515/article/details/91852409