PAT甲级——1116 Come on! Let's C (水题)

1116 Come on! Let's C (20 分)

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

 根据排好序的人员名单进行奖品分配,第一名获得“Mystery Award”,排名为素数的人获得“Minion”,其余的人获得“Chocolate”,已经查询过的人再次查询时输出“Checked”,若查询的人不在名单中,则输出“Are you kidding?”

#include <iostream>
#include <unordered_map>
#include <cmath>
using namespace std;
bool isPrime(int n);
int main()
{
	int N, ID, Q;
	unordered_map <int, int> List;
	scanf("%d", &N);
	for (int i = 1; i <= N; i++) {
		scanf("%d", &ID);
		if (i == 1)
			List[ID] = 1;
		else if (isPrime(i))
			List[ID] = 2;
		else
			List[ID] = 3;
	}
	scanf("%d", &Q);
	for (int i = 0; i < Q; i++) {
		scanf("%d", &ID);
		if (List[ID] == 1) {
			printf("%04d: Mystery Award\n",ID);
			List[ID] = 4;
		}
		else if (List[ID] == 2) {
			printf("%04d: Minion\n",ID);
			List[ID] = 4;
		}
		else if (List[ID] == 3) {
			printf("%04d: Chocolate\n",ID);
			List[ID] = 4;
		}
		else if (List[ID] == 4) {
			printf("%04d: Checked\n",ID);
		}
		else {
			printf("%04d: Are you kidding?\n",ID);
		}
	}
	return 0;
}
bool isPrime(int n) {
	if (n == 1) 
		return false;
	int k = sqrt(n);
	for (int i = 2; i <= k; i++) 
		if (n%i == 0) 
			return false;
	return true;
}

猜你喜欢

转载自blog.csdn.net/weixin_44385565/article/details/89855311