1116 Come on! Let's C (20 分)

版权声明:SupremeBeast3_ https://blog.csdn.net/weixin_43359312/article/details/89148489

1116 Come on! Let’s C (20 分)

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
1、 Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
2、 Everyone else will receive chocolates.
Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤104), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:
For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
Sample Output:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

AC代码

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;
int isPrime(int N);
int main() {
	int N;
	cin >> N;
	int Num[10001];
	for (int i = 1; i <= N; i++) cin >> Num[i];
	int K;
	cin >> K;
	int TheNum;
	int Judge[10001] = { 0 };
	for (int i = 1; i <= K; i++) {
		cin >> TheNum;
		if (TheNum == Num[1]) {
			if (!Judge[1]) { Judge[1] = 1; printf("%04d: Mystery Award\n", TheNum); }
			else printf("%04d: Checked\n", TheNum);
		}
		else {
			int flag = 0;
			for (int j = 1; j <= N; j++) {
				if (TheNum == Num[j]) {
					if (!Judge[j]) {
						Judge[j] = 1;
						flag = 1;
						if (isPrime(j)) printf("%04d: Minion\n", TheNum);
						else printf("%04d: Chocolate\n", TheNum);
					}
					else { printf("%04d: Checked\n", TheNum); flag = 1; }
				}
			}
			if (!flag) printf("%04d: Are you kidding?\n", TheNum);
		}
	}
	return 0;
}
int isPrime(int N) {
	int ret = 1;
	if (N == 1) return 0;
	for (int i = 2; i <= sqrt(N); i++) if (!(N%i)) { ret = 0; break; }
	return ret;
}

猜你喜欢

转载自blog.csdn.net/weixin_43359312/article/details/89148489