【OJ-1197】约瑟夫问题

n个人想玩残酷的死亡游戏,游戏规则如下: 

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。

Input

输入n和m值。

Output

输出胜利者的编号。

Sample Input

5 3

Sample Output

4

#include <stdio.h>
#include <stdlib.h>
struct node
{
   int data;
   struct node *next;
};

struct node* creat(int n)
{
    int i;
    struct node *head, *p, *tail;
    head=(struct node*)malloc(sizeof(struct node));
    head->data=1;
    tail=head;
    for(i=2; i<=n; i++)
    {
      p=(struct node*)malloc(sizeof(struct node));
      p->data=i;
      tail->next=p;
      tail=p;
    }
    p->next=head;
    return head;
}

int f(int n,int m, struct node *head)
{
    int count=0,num=0;
    struct node *p,*q;
    p=head;
    q=head;
    while(q->next!=head)
    {
        q=q->next;
    }
    while(count!=n-1)
    {
        num++;
        if(num%m!=0)
        {
            p=p->next;
            q=q->next;
        }
        else
        {
            q->next=p->next;
            p=q->next;
            count++;
        }
    }
    return p->data;
}

int main()
{
    int n,m;
    struct node *head;
    scanf("%d %d",&n,&m);
    head=creat(n);
    printf("%d\n",f(n,m,head));
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44153125/article/details/89105912