杭电1005

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_23301703/article/details/82379512

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 203604    Accepted Submission(s): 51371


 

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

 

1 1 3 1 2 10 0 0 0

 

Sample Output

 

2 5

此题,最开始以为是动态规划直接硬解,发现是有规律的。

由公式 (a+b)%c = a%c + b%c;

a % 7 = 0 - 6 总共7种状态

b % 7 = 0 - 6 共7种状态

所以只需要算出49种状态然后取余查表即可。

代码

#include<iostream>
#include<stdlib.h>
using namespace std;
int main()
{
	int A,B,n,i;
	while(cin >> A >> B >> n)
	{
		if(A==0&&B==0&&n==0)
			break;
		//总共49种
		int res[50];
		res[1]=1;
		res[2]=1;
		//填表
		for(i=3;i<50;i++)
			res[i] = (res[i-1]*A+res[i-2]*B)%7;
		//查表
		cout << res[n%49] << endl;
	}
}

已经AC。

猜你喜欢

转载自blog.csdn.net/qq_23301703/article/details/82379512