Sicily 1119. Factstone Benchmark

  1. Factstone Benchmark
    Constraints
    Time Limit: 1 secs, Memory Limit: 32 MB
    Description
    Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)
    Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.
    Input
    Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel’s most recently released chip?
    Output
    There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.
    Sample Input
    1960
    1981
    0
    Sample Output
    3
    8
    这道题先给出年份,根据年份求出位数n,然后需要求出一个x,使得x!正好小于2的n次方,在这里我们可以通过对两边同时取对数减少运算量, 即log2+…+logn<n,代码如下
    在这里插入图片描述
#include<iostream>
#include<cmath>
using namespace std;
int main(){
	int year;
	while(cin>>year&&year!=0){
		year/=10;
		int k=year-194;
		k=pow(2,k);
		double n=1;
		double sum=0;
		while(sum<k){
			n++;
			sum+=log(n)/log(2);
		}
		cout<<n-1<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/dcy19991116/article/details/89471712
今日推荐