Sicily 1500. Prime Gap

  1. Prime Gap
    Constraints
    Time Limit: 1 secs, Memory Limit: 32 MB
    Description
    The sequence of n ? 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, 24, 25, 26, 27, 28 between 23 and 29 is a prime gap of length 6.
    Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.
    Input
    The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.
    Output
    The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.
    Sample Input
    10
    11
    27
    2
    492170
    0
    Sample Output
    4
    0
    6
    0
    114
    这道题题意是给出一个数n,找一个小于它的最大的正数,以及一个大于它的最小的质数,可以以给出的数字为基准点,分别向前和向后拓展,遇到质数就停下来,并标记距离,代码如下
    在这里插入图片描述
    其中用到判断一个数是否为质数的函数
    在这里插入图片描述

```#include<iostream>
#include<cmath>
using namespace std;
bool isprime(int n){
	for(int i=2;i<=sqrt(n);i++){
		if(n%i==0){
			return false;
		}
	}
	return true;
}
int main(){
	int num;
	while(cin>>num&&num!=0){
		int ans=0;
		if(isprime(num)){
			cout<<ans<<endl;
		}
		else{
			int temp1=num;
			while(!isprime(temp1)){
				temp1++;
			}
			int temp2=num;
			while(!isprime(temp2)){
				temp2--;
			}
			ans=temp1-temp2;
			cout<<ans<<endl;
		}
	}
}


猜你喜欢

转载自blog.csdn.net/dcy19991116/article/details/89472157
GAP
GAP
今日推荐