ZOJ - 3939 The Lucky Week (规律)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89055350

The Lucky Week

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3939

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week "The Lucky Week".

But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

The only line contains four integers Y, M, D and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward's query N.

The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).

Output

For each case, print the date of the Monday of the N-th Lucky Week.

Sample Input

2
2016 4 11 2
2016 1 11 10

Sample Output

2016 7 11
2017 9 11

题目大意: t组数据,每组数据给 你年月日,并且这是一个幸运周,问从这一天起的第k个幸运周的日期,(幸运周:是这一周的星期一,并且是这个月的1 11 或 21日)

思路: 400年是一个轮回,每四百年有2058个幸运周,对于2058以内的直接模拟,每次d+7,判断一下这天是不是1 ,11  或者21

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mo[15]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int fun(int x)
{
    if(x%4==0&&x%100!=0||x%400==0)
        return 1;
    return 0;
}
int main()
{
    int y,m,d,t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&y,&m,&d,&n);
        y+=(n/2058)*400;
        n%=2058;
        while(n)
        {
            if(d==11||d==21||d==1) n--;
            if(n==0) break;
            if(fun(y)) mo[2]=29;
            else mo[2]=28;
            d+=7;
            if(d>mo[m])
            {
                d-=mo[m];
                m++;
            }
            if(m>12)
            {
                m=1;
                y++;
            }
        }
        printf("%d %d %d\n",y,m,d);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89055350
ZOJ
今日推荐