天梯练习赛 周游世界

周游世界 (30 分)

周游世界是件浪漫事,但规划旅行路线就不一定了…… 全世界有成千上万条航线、铁路线、大巴线,令人眼花缭乱。所以旅行社会选择部分运输公司组成联盟,每家公司提供一条线路,然后帮助客户规划由联盟内企业支持的旅行路线。本题就要求你帮旅行社实现一个自动规划路线的程序,使得对任何给定的起点和终点,可以找出最顺畅的路线。所谓“最顺畅”,首先是指中途经停站最少;如果经停站一样多,则取需要换乘线路次数最少的路线。

输入格式:

输入在第一行给出一个正整数N(≤100),即联盟公司的数量。接下来有N行,第i行(i=1,⋯,N)描述了第i家公司所提供的线路。格式为:

M S[1] S[2] ⋯ S[M]

其中M(≤100)是经停站的数量,S[i](i=1,⋯,M)是经停站的编号(由4位0-9的数字组成)。这里假设每条线路都是简单的一条可以双向运行的链路,并且输入保证是按照正确的经停顺序给出的 —— 也就是说,任意一对相邻的S[i]和S[i+1](i=1,⋯,M−1)之间都不存在其他经停站点。我们称相邻站点之间的线路为一个运营区间,每个运营区间只承包给一家公司。环线是有可能存在的,但不会不经停任何中间站点就从出发地回到出发地。当然,不同公司的线路是可能在某些站点有交叉的,这些站点就是客户的换乘点,我们假设任意换乘点涉及的不同公司的线路都不超过5条。

在描述了联盟线路之后,题目将给出一个正整数K(≤10),随后K行,每行给出一位客户的需求,即始发地的编号和目的地的编号,中间以一空格分隔。

输出格式:

处理每一位客户的需求。如果没有现成的线路可以使其到达目的地,就在一行中输出“Sorry, no line is available.”;如果目的地可达,则首先在一行中输出最顺畅路线的经停站数量(始发地和目的地不包括在内),然后按下列格式给出旅行路线:

Go by the line of company #X1 from S1 to S2.
Go by the line of company #X2 from S2 to S3.
......

其中Xi是线路承包公司的编号,Si是经停站的编号。但必须只输出始发地、换乘点和目的地,不能输出中间的经停站。题目保证满足要求的路线是唯一的。

输入样例:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
4
3011 3013
6666 2001
2004 3001
2222 6666

输出样例:   

2
Go by the line of company #3 from 3011 to 3013.
10
Go by the line of company #4 from 6666 to 1306.
Go by the line of company #3 from 1306 to 2302.
Go by the line of company #2 from 2302 to 2001.
6
Go by the line of company #2 from 2004 to 1204.
Go by the line of company #1 from 1204 to 1306.
Go by the line of company #3 from 1306 to 3001.
Sorry, no line is available.

解题思路:首先能确定是最短路问题,当时是用spfa写的,但是输出路径理解错误了,只有15分。看了网上的题解可以用dfs,就重新用dfs写了一遍。只要明白题目让输出的是什么就可以了。

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define sca(x) scanf("%d",&x)
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define pb(x) push_back(x)
#define N 100005
#define inf 0x3f3f3f3f
#define mp(x,y) make_pair(x,y)

int n;
vector<int>V[N];
map<pair<int,int>,int>mmp;
int a[N];
int id[N];
void add(int x,int k)
{
    int u,v;
    for(int i=2;i<=k;i++)
    {
        u=a[i],v=a[i-1];
        V[u].pb(v);
        V[v].pb(u);
        mmp[mp(u,v)]=x;
        mmp[mp(v,u)]=x;
    }
}

void  input( )
{
    sca(n);
    rep(i,1,n)
    {
        int k;
        sca(k);
        rep(j,1,k)sca(a[j]);
        add(i,k);
    }
}

int point,flag;
int path[N],path1[N];
int vis[N];

bool judge(int dep)
{
    int cnt1=0,cnt2=0;
    int now=mmp[mp(path[1],path[2])];
    for(int i=2;i+1<=dep;i++)
    {
        if(mmp[mp(path[i],path[i+1])]!=now)cnt1++;
        now=mmp[mp(path[i],path[i+1])];
    }
    now=mmp[mp(path1[1],path1[2])];
    for(int i=2;i+1<=dep;i++)
    {
        if(mmp[mp(path1[i],path1[i+1])]!=now)cnt2++;
        now=mmp[mp(path1[i],path1[i+1])];
    }
    return cnt2<cnt1;
}

void dfs(int s,int t,int dep)
{
    path1[dep]=s;
    if(s==t)
    {
        flag=1;
        if(dep<point)
        {
            point=dep;
            for(int i=1;i<=dep;i++)path[i]=path1[i];
        }
        else if(dep==point)
        {
            if(judge(dep))
            {
                for(int i=1;i<=dep;i++)path[i]=path1[i];
            }
        }
        return ;
    }
    for(int i=0;i<V[s].size();i++)
    {
        int v=V[s][i];
        if(vis[v])continue;
        vis[v]=1;
        dfs(v,t,dep+1);
        vis[v]=0;
    }
}

void solve()
{
    int m;
    sca(m);
    while(m--)
    {
        int s,t;
        sca(s),sca(t);
        point=inf;
        flag=0;
        memset(vis,0,sizeof(vis));
        dfs(s,t,1);
        if(flag)
        {
            cout<<point-1<<endl;
            queue<int>q;
            int now=mmp[mp(path[1],path[2])];
            int ou=1;
            a[ou++]=s;
            id[1]=now;
            for(int i=2;i+1<=point;i++)
            {
                if(mmp[mp(path[i],path[i+1])]!=now)id[ou]=mmp[mp(path[i],path[i+1])],a[ou++]=path[i];
                now=mmp[mp(path[i],path[i+1])];
            }
            a[ou]=t;
            for(int i=1;i+1<=ou;i++)
            {
                printf("Go by the line of company #%d from %04d to %04d.\n",id[i],a[i],a[i+1]);
            }
        }
        else puts("Sorry, no line is available.");
    }
}
int main()
{
    input();
    solve();
}

猜你喜欢

转载自blog.csdn.net/weixin_40894017/article/details/88527865
今日推荐