Bulbs

问题 B: Bulbs
时间限制: 1 Sec 内存限制: 128 MB
提交: 274 解决: 162
[提交] [状态] [命题人:admin]
题目描述
Greg has an m × n grid of Sweet Lightbulbs of Pure Coolness he would like to turn on. Initially, some of the bulbs are on and some are off. Greg can toggle some bulbs by shooting his laser at them. When he shoots his laser at a bulb, it toggles that bulb between on and off. But, it also toggles every bulb directly below it,and every bulb directly to the left of it. What is the smallest number of times that Greg needs to shoot his laser to turn all the bulbs on?

输入
The first line of input contains a single integer T (1 ≤ T ≤ 10), the number of test cases. Each test case starts with a line containing two space-separated integers m and n (1 ≤ m, n ≤ 400). The next m lines each consist of a string of length n of 1s and 0s. A 1 indicates a bulb which is on, and a 0 represents a bulb which is off.

输出
For each test case, output a single line containing the minimum number of times Greg has to shoot his laser to turn on all the bulbs.

样例输入
复制样例数据
2
3 4
0000
1110
1110
2 2
10
00
样例输出
1
2

提示
In the first test case, shooting a laser at the top right bulb turns on all the bulbs which are off, and does not
toggle any bulbs which are on.
In the second test case, shooting the top left and top right bulbs will do the job.

不会高斯消元解异或方程组

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
#include <queue>
#include <stack>
#define inf 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const long long mod = 1e9 + 7;
using namespace std;
typedef long long ll;
 
const int maxn = 100010;
int main()
{
    int t;
    cin >> t;
    int m, n;
    while (t--)
    {
        cin >> m >> n;
        char s[m+5][n+5];
        int d = 0;
        for (int i=0;i<m;i++)
        {
            cin >> s[i];
        }
        for (int i=0;i<m;i++)
        {
            for (int j=n-1;j>=0;j--)
            {
                if (s[i][j] == '0')
                {
                    d++;
                    for (int k=j;k>=0;k--)
                    {
                        if (s[i][k] == '0')
                            s[i][k] = '1';
                        else s[i][k] = '0';
                    }
                    for (int g=i+1;g<m;g++)
                    {
                        if (s[g][j] == '0')
                            s[g][j] = '1';
                        else s[g][j] = '0';
                    }
                }
            }
        }
        cout << d << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/abc1235454/article/details/89233008