UVA - 10020- Minimal coverage (区间覆盖)

UVA - 10020- Minimal coverage (区间覆盖)

Given several segments of line (int the X axis) with coordinates [Li
, Ri
]. You are to choose the minimal
amount of them, such they would completely cover the segment [0, M].
Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”
(|Li
|, |Ri
| ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair
‘0 0’.
Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line
segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0
Sample Output
0
1
0 1

题目大意:

给你个区间[l,r] 然后给你一些线段,每条线段都有一个l[i],r[i]问,最少用多少个线段覆盖这个区间,如果没有输出-1.

解题思路:

典型的区间覆盖。
具体介绍看我上一篇博客。。。

  • AC代码:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn=1e5+10;
struct node{
	int left;
	int right;
}side[maxn],ans[maxn];
bool cmp(struct node a,struct node b)
{
	return a.right>b.right;
}
bool cmp2(struct node a,struct node b)
{
	return a.left<b.left;
}

int m;
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		cin>>m;
		int right=m;
		int left=0;
		int l,r;
		int cnt=0;
		while(cin>>l>>r)
		{
			if(l==0&&r==0)
				break;
			side[cnt].left=l;
			side[cnt].right=r;
			cnt++;
		}
		sort(side,side+cnt,cmp);
	
		
		int cnt2=0;

		while(left<right)
		{
			int i=0;
		//	cout<<"s"<<endl;
			for( i=0;i<cnt;i++)
			{
				if(side[i].left<=left&&side[i].right>left)
				{
					ans[cnt2++]=side[i];
					left=side[i].right;//更新区间
					break;
				}
			}
			if(i==cnt)///找了一圈没有合适的
			{
				break;
			}
		}
		if(left<right)
			cout<<"0"<<endl;
		else
		{
			cout<<cnt2<<endl;
		//	sort(ans,ans+cnt2,cmp2);
			for(int i=0;i<cnt2;i++)
			{
				cout<<ans[i].left<<" "<<ans[i].right<<endl;
			}
		}
		if(T)
			cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43179892/article/details/84864117
今日推荐