Uva 10382 Watering Grass(贪心区间覆盖+)

n sprinklers are installed in a horizontal strip of grass l meters long andw meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?


Input

Input consists of a number of cases. The first line for each case contains integer numbersn, l and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input
8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

Sample Output

6
2

-1

题意:给定一条草坪。草坪上有n个喷水装置。草坪长l米宽w米。。n个装置都有每个装置的位置和喷水半径。。要求出最少需要几个喷水装置才能喷满草坪。。喷水装置都是装在草坪中间一条水平线上的。。

思路;注意先把圆的覆盖转化成矩形的覆盖,用勾股定理很简单

      剩下的很容易想到是贪心区间覆盖问题,但是我看了网上好几个博客都没有看懂,我想的是按区间的左端点从小到大排序,然后每次都找左端点小于当前右边界的,且右端点最大的那个点,然后将右边界的值更新为那个右端点,依次循环。。。。

我觉得这才是区间覆盖的做法吧,不明白网上那些高访问的是啥意思。。。。

这个题的边界数据是浮点数,所以最好不要用“=”,用精确度来表示比较好,虽然这个题好像不用也能过

剩下的东西我都写在代码的注释里了

这个题我WA了十多次你敢信,真的自闭了

#include<cstdio>  
#include<algorithm>  
#include<iostream>  
#include<cmath>  
using namespace std;  
const int MAXN=10000+10;  
struct node  
{  
    double l,r;  
    /* 
    bool operator <(const sprinkler &x)const  
    {  
        return l<x.l;  
    } 
	*/ 
}sp[MAXN];  
bool cmp(const node &a,const node &b)
{
	return a.l<b.l;
}
int main()  
{  
    int n,len,w;  
    while(scanf("%d%d%d",&n,&len,&w)!=EOF)  
    {  
        int cnt=0,x;  
          
        double r,temp;    
        for(int i=0;i<n;i++)  
        {  
            scanf("%d%lf",&x,&r);  
  
            if(r*2 <= w)         //注意等号 
                continue;  
            temp=sqrt(r*r-w*w/4.0);  
            sp[cnt].l=x-temp;  
            sp[cnt].r=x+temp;  
            cnt++;  
        }  
  
        sort(sp,sp+cnt,cmp);//按最左边的距离排序  
  
        double L=0,R=len,maxx;  
          
        int ans=0;  
        while(L<R)  
        {  
            maxx=0;  
            for(int i=0;i<cnt;i++)   
                if( sp[i].l-L <1e-16  )  
                    maxx=max(maxx,sp[i].r); //找到最大的右边界 
  
            if(fabs(maxx-L)<1e-16)   //这里是为了判断maxx是不是还是上次找到的, 
            {     ans=-1; break;    }  //也就是如果没有找到新的符合要求的点,那么就不能覆盖 
          
            ans++;  
            L=maxx;  
        }  
  
        printf("%d\n",ans);  
    }  
} 

猜你喜欢

转载自blog.csdn.net/zvenWang/article/details/84867901
今日推荐