贪心 C - Radar Installation

在这里插入图片描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

AC代码:

//贪心,主要弄清排序原则,,遍历的过程
//用代码实现自己的想法才行。。
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<math.h>
using namespace std;
struct stu
{
    double l,r;//能被覆盖的所有圆中,左端点和右端点
}I[1005];
bool cmp(stu a,stu b)
{
    //右端点从小到大排序,右端点相同时,按照左端点从大到小排序
    if(a.r==b.r)
        return a.l>b.l;
    return a.r<b.r;
}
int main()
{
    int k=1;
    int n,d;
    double x,y;
    while(cin>>n>>d && n)
    {
        int flag=0;
        for(int i=0;i<n;i++)
        {
            cin>>x>>y;
            I[i].l=x-sqrt(d*d-y*y);
            I[i].r=x+sqrt(d*d-y*y);
            if(d<y || d<0)//不够,或者半径<0
                flag=1;
        }
        if(flag)
             printf("Case %d: -1\n",k++);
        else
        {
            sort(I,I+n,cmp);
            int ans=1;
            double post=I[0].r;//初始,右端点
            for(int i=1;i<n;i++)
            {
                if(I[i].l>post)//超过上一个范围的最大值了
                {
                    ans++;
                    post=I[i].r;//不断更新右端点
                }
            }
            printf("Case %d: %d\n",k++,ans);
        }
    }
    return 0;
}

具体思路见https://blog.csdn.net/qq_42891420/article/details/89086025

猜你喜欢

转载自blog.csdn.net/weixin_43250284/article/details/89105987