概率悖论

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

问有多少个人在一块能保证两个人生日是同一天的概率>0.5

任何人都不在同一天的概率是n/n   *   (n-1)/n   *  (n-2)/n......那么1-n/n   *   (n-1)/n   *  (n-2)/n......就是答案了。

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t;
    cin>>t;
    for(int k=1;k<=t;k++)
    {
        int n;
        cin>>n;
        double sum=1;
        int ans=n;
        for(int i=n;i>=0;i--)
        {
            sum*=i*1.0/n;
            if(sum<=0.5)
            {
                ans=i;
                break;
            }
        }
        printf("Case %d: %d\n",k,n-ans);
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/88978626