Dight Counting(字符串转数字)

题目

Trung is bored with his mathematics homeworks.He takes a piece of chalk and starts writing a sequence of consecutive integers starting with1 to N (1<N<10000).After that,he counts the number of times each digit (0 to 9) appears in these quence.For example,with N=13,these quenceis:
12345678910111213
In this sequence,0appears once,1 appears 6times,2 appears 2times,3 appears 3times,and each
digit from 4 to 9 appears once.After playing for a while,Trung gets bored again.He now wants to
write a program to do this for him.Your task is to help him with writing this program.

Input

The input file consists of several data sets.The first line of the input file contains the number of data
sets which is apositive integerand is not bigger than 20.The following lines describe the datasets.
For each test case,there is one single line containing the number N.

Output

For each test case,write sequentially in one line the number of digit 0,1,…9 separated by a space.

SampleInput

2
3
13

SampleOutput

0111000000
1622111111

分析

这个提要求的是1-n组成的字符串中0、1、2、3······9的个数。输入后直接遍历即可。

代码+注释
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int T;
    int n;
    int l[15];
    cin>>T;
    while(T--)
    {
        memset(l,0,sizeof(l));        //由于有多组数据,每次输入n前把数组清零。
        cin>>n;
        for(int i=1;i<=n;i++)      //遍历1~n。
        {
            int j=i;
            while(j!=0)       //将数字i看做字符串并不断取余除十。
            {
                int a=j%10;
                l[a]++;
                j/=10;
            }
        }
        for(int i=0;i<9;i++)       //分别输出0~9的个数。
            cout<<l[i]<<" ";
        cout<<l[9]<<endl;        //防止提交时格式错误。
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43105110/article/details/88081760