调和级数+欧拉常数

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double sum[1000005];
int main()
{
    double s=0;
    sum[0]=0;
    for(int i=1;i<=1e8;i++)
    {
        s+=1.0/i;
        if(i%100==0)
        {
            sum[i/100]=s;
        }
    }
    int n,cas;
    scanf("%d",&cas);
    for(int tt=1;tt<=cas;tt++)
    {
        scanf("%d",&n);
        double ans=sum[n/100];
        for(int i=(n/100)*100+1;i<=n;i++)
        {
            ans+=1.0/i;
        }
        printf("Case %d: %.10lf\n",tt,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/88665414