HDU - 1535 Invitation Cards

题目:
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210
代码如下:

#include<bits/stdc++.h>
using namespace std;
#define MAX 1000005
#define NIL 0x3f3f3f3f
int t,n,m,dis[MAX];
bool vis[MAX];
vector<pair<int,int> >mp[MAX];
struct Node
{
    int x,y,z;
}node[MAX];
void Dijkstra(int i)
{
    memset(dis,NIL,sizeof(dis));
    memset(vis,false,sizeof(vis));
    dis[i] = 0;
    priority_queue<int> q;
    q.push(i);
    while(!q.empty()){
        int flag = q.top();
        q.pop();
        vis[flag] = true;
        for(int i = 0;i < mp[flag].size();i++){
            if(dis[mp[flag][i].first] > dis[flag] + mp[flag][i].second){
                dis[mp[flag][i].first] = dis[flag] + mp[flag][i].second;
                q.push(mp[flag][i].first);
            }
        }
    }
}
int main()
{
    int sum;
    cin >> t;
    while(t--){
        sum = 0;
        cin >> n >> m;
        for(int i = 0;i <= n;i++) mp[i].clear();
        for(int i = 0;i < m;i++){//创建邻接表
            cin >> node[i].x >> node[i].y >> node[i].z;
            mp[node[i].x].push_back(make_pair(node[i].y,node[i].z));
        }
        Dijkstra(1);//计算从1走到各点的最短距离
        for(int i = 1;i <= n;i++) sum += dis[i];
        for(int i = 0;i <= n;i++) mp[i].clear();
        for(int i = 0;i < m;i++) mp[node[i].y].push_back(make_pair(node[i].x,node[i].z));
        Dijkstra(1);//计算从各地走到原点的最短距离
        for(int i = 1;i <= n;i++) sum += dis[i];
        cout << sum << endl;
    }
    return 0;
}

题意:
输入数据组数,然后输入点的个数和边的个数,随后输入每条边的起点,终点以及相应权值。让你计算点1到其他点最短距离之和加上其他点到点1的最短距离。
思路:
单单计算从起点到其他点的最短距离之和,直接用Dijkstra算法就可以了,问题是如何去计算其他点到原点的最短距离。因为输入的是有向图,我们只需要把每条通道的方向反一下,然后计算原点到其他点的距离就可以得出答案。但是做的过程中还是遇到了问题,刚开始我用了两个vector<pair(int,int)> q[MAX],目的是一个保存题目中输入的路径,一个保存反向路径,随后用两次Dijkstra算法,但是空间超了。后来用结构体保存刚开始输入的每条边的状态,然后使用同一个vector去计算,这才成功AC了。

猜你喜欢

转载自blog.csdn.net/qq_41998938/article/details/88899822