HDU - 1535 - Invitation Cards (spfa & 双向遍历)

HDU - 1535 - Invitation Cards

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210

题目链接1(可提交判错)
原题链接

这个题目的意思就是,给你一些点,然后构成一个有向图,让你从a点出发,到每个点往返一次,求最短路径之和。就是1到2,1到3……的最短路径之和加上再从那些点回来的最短路径加和。

一开始想的是Dijkstra找1到每个点的最短路,然后加上回来的路,枚举暴力,结果果断t了。然后就觉得应该是spfa吧,因为是要把所有点上的边都遍历一遍,所以一次调用dis数组就会把所有点的最短路径记录下来,但有好多大佬都说Dijkstra也可以,但我这个小菜鸡不会啊,所以还是用了spfa。
主要就是需要两次,去一次,回来一次,所以我选择用结构体记录边的起始和结束位置,第二次的时候倒过来就好了。
AC代码:

#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6+5;
int dis[maxn], head[maxn], book[maxn];
int cnt;

struct edge
{
    int to, w, ne;
}e[maxn];

struct node
{
    int f, t, w;
}no[maxn];

void init()
{
    cnt = 0;
    memset(book, 0, sizeof(book));
    memset(head, -1, sizeof(head));
    memset(dis, inf, sizeof(dis));
}

void add(int a, int b, int w)
{
    e[cnt].to = b;
    e[cnt].w = w;
    e[cnt].ne = head[a];
    head[a] = cnt++;
}

void Dijkstra()
{
    queue<int> q;
    dis[1] = 0;
    q.push(1);

    while(q.size())
    {
        int temp = q.front();
        q.pop();

        book[temp] = 0;
        for(int i = head[temp]; i != -1; i = e[i].ne)
        {
            int id = e[i].to;
            if(dis[id] > dis[temp] + e[i].w)
            {
                dis[id] = dis[temp] + e[i].w;
                if(!book[id])
                {
                    q.push(id);
                    book[id] = 1;
                }
            }
        }
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, m, sum = 0;
        scanf("%d%d", &n, &m);
        for(int i = 0; i < m; i++)  scanf("%d%d%d", &no[i].f, &no[i].t, &no[i].w);
        init();
        for(int i = 0; i < m; i++)  add(no[i].f, no[i].t, no[i].w);
        Dijkstra();
        for(int i = 1; i <= n; i++) sum += dis[i];
        init();
        for(int i = 0; i < m; i++)  add(no[i].t, no[i].f, no[i].w);
        Dijkstra();
        for(int i = 1; i <= n; i++) sum += dis[i];
        printf("%d\n", sum);
    }
    return 0;
}

有关和的计算可以放到spfa里面,以参数方式返回,结构体也不需要定义两个,可以用一个,只要能想清楚,这样可以减少一丢丢代码量,个人比较喜欢美观整齐的代码,尽量精简。。。。(表示菜鸡也想追求一下高大尚)

猜你喜欢

转载自blog.csdn.net/weixin_40788897/article/details/81408436