POJ1511:Invitation Cards(最短路)

Invitation Cards

Time Limit: 8000MS   Memory Limit: 262144K
Total Submissions: 34743   Accepted: 11481

题目链接:http://poj.org/problem?id=1511

Description:

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input:

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output:

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input:

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output:

46
210

题意:

扫描二维码关注公众号,回复: 5148509 查看本文章

给出一个有向图,边权都为正数,然后求从1到2~n-1号点,再从2~n-1号点回到1的最小花费。

题解:

这题主要是求回到1点时的最小花费,其实我们只需要把边反向后再跑一次最短路即可。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 1e6+5 ;
int t,p,q;
int vis[N],head[N];
ll d[N];
struct E{
    int u,v,w;
}g[N];
struct Edge{
    int u,v,w,next ;
}e[N<<1];
int tot;
struct node{
    int u;
    ll d;
    bool operator < (const node &A)const{
        return d>A.d;
    }
};
void adde(int u,int v,int w){
    e[tot].v=v;e[tot].w=w;e[tot].next=head[u];head[u]=tot++;
}
void Dijkstra(int s){
    priority_queue <node> q;memset(d,INF,sizeof(d));
    memset(vis,0,sizeof(vis));d[s]=0;
    node now;
    now.d=0;now.u=s;
    q.push(now);
    while(!q.empty()){
        node cur = q.top();q.pop();
        int u=cur.u;
        if(vis[u]) continue ;
        vis[cur.u]=1;
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(d[v]>d[u]+e[i].w){
                d[v]=d[u]+e[i].w;
                now.d=d[v];now.u=v;
                q.push(now);
            }
        }
    }
}
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&p,&q);
        for(int i=1;i<=q;i++){
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            g[i].u=u;g[i].v=v;g[i].w=w;
        }
        memset(head,-1,sizeof(head));tot=0;
        ll ans = 0;
        for(int i=1;i<=q;i++) adde(g[i].u,g[i].v,g[i].w);
        Dijkstra(1);
        for(int i=2;i<=p;i++) ans+=d[i];
        memset(head,-1,sizeof(head));tot=0;
        for(int i=1;i<=q;i++) adde(g[i].v,g[i].u,g[i].w);
        Dijkstra(1);
        for(int i=2;i<=p;i++) ans+=d[i];
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/heyuhhh/p/10352025.html