Fliptile (dfs+二进制压缩)

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

这个题挺不错,利用了枚举所有情况,枚举的时候利用二进制的性质,然后再暴力各个方向,考虑如果翻转之后对别的有什么影响,如果上一行是黑色,这个必然要翻,再判断一下最后一行是否为全白

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<cmath>
#define Inf 0x3f3f3f3f
 
const int maxn=1e5+5;
typedef long long ll;
using  namespace std;
int Map[25][25];
int num[25][25];
int s[25][25];
int dir[5][2]={{0,0},{0,-1},{0,1},{-1,0},{1,0}};
int n,m;
bool check(int x,int y)
{
	if(x>=0&&x<n&&y>=0&&y<m)
	{
		return true;
	}
	else
	{
		return false;
	}
}
int fun(int x,int y)
{
	int res=Map[x][y];
	for(int t=0;t<5;t++)
	{
		int xx=x+dir[t][0];
		int yy=y+dir[t][1];
		if(check(xx,yy))
		{
			res+=num[xx][yy];
		}
	}
	return res%2;
}
int cal()
{
	for(int t=1;t<n;t++)
	{
		for(int j=0;j<m;j++)
		{
			if(fun(t-1,j))
		    {
		    	num[t][j]=1;
			}
		}
	}
	for(int t=0;t<m;t++)
	{
		if(fun(n-1,t))
		{
			return -1;
		}
	}
	int res=0;
	for(int t=0;t<n;t++)
	{
		for(int j=0;j<m;j++)
		{
			res+=num[t][j];
		}
	}
	return res;
}


int main()
{

	cin>>n>>m;
	for(int t=0;t<n;t++)
	{
		for(int j=0;j<m;j++)
		{
			scanf("%d",&Map[t][j]);
		}
	}
	int ans=Inf;
	for(int t=0;t<1<<m;t++)
	{
		memset(num,0,sizeof(num));
		for(int j=0;j<m;j++)
		{
			num[0][m-1-j]=t>>j&1;
		}
		
		int cnt=cal();
		if(cnt>=0&&cnt<ans)
		{
			ans=cnt;
			memcpy(s,num,sizeof(num));
		}
	}
	if(ans==Inf)
	{
		cout<<"IMPOSSIBLE\n";
	}
	else
	{
		for(int t=0;t<n;t++)
		{
			for(int j=0;j<m;j++)
			{
				if(j==m-1)
				{
					cout<<s[t][j]<<endl;
				}
				else
				{
					cout<<s[t][j]<<" ";
				}
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lbperfect123/article/details/88856591
今日推荐