POJ3279 Fliptile(DFS翻转经典问题)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/UncleJokerly/article/details/83350989

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

[kuangbin带你飞]专题一 简单搜索D - Fliptile(POJ 3279)

题意:

给一个N行M列的矩阵,值分别为0和1,每次你可以选择将一个变成相反状态,同时,它周围的四个数也会变为相反状态。 
问:最少翻转多少次,可以将所有值都变成0 
多个解,输出翻转次数最少的(若有次数相同解,输出字典序小的) 
若无解,输出”IMPOSSIBLE”

解题思路:

对于每个点,只能有两种操作,翻或不翻,若暴力所有可能性,需要2^(M*N)次操作,显然不可行 
所以有了这个法子。 
先枚举第一行的所有可能性(2^M),搜索或位运算均可 
然后,对坐标(i, j)来说,如果(i-1, j)不为0,那么(i, j)必然需要翻转。 
重复进行上操作由2至N 
此时,最后一行也已翻转完毕,如果最后一行全为0,得出结果 
第一行的所有结果中取最小值
 

有点绕。

为了求第二行到最后一行的翻转状态我们需要确定前一行的状态。我们枚举第一行所有的情况,每枚举一种情况(第一行在此次枚举中不变了)就搜索一下所有可能的结果,不断更新状态。

AC代码:

#include<cstdio>
#include<cstring>

int n,m;
int mp[20][20];
int f[20][20]={};
int ans[20][20]={};
int minn=0x1f1ffff;

bool judge()//判断最后一行是否全为0 
{
	for(int i=1;i<=m;i++)
	{
		int t=f[n][i]+f[n][i-1]+f[n][i+1]+f[n-1][i];
		if((mp[n][i]+t)&1) return false;
	}
	return true;
}
//k是当前行 
void dfs(int k,int num)
{
	if(num>minn) return;//剪枝 
	if(k>n)
	{
		if(judge()&&num<minn)//判断是否符合条件 
		{
			memcpy(ans,f,sizeof(f));//记录当前最优解 
			minn=num;//更新翻转最小次数 
		}
		return;
	}
	int t=0;
	for(int i=1;i<=m;i++)
	{ 
		if((mp[k-1][i]+f[k-2][i]+f[k-1][i-1]+f[k-1][i+1]+f[k-1][i])&1)//上一行mp[k-1][i]是否为1 即是否需要翻转
		{
			f[k][i]=1;
			t++;
		}
		else f[k][i]=0;
	}
	dfs(k+1,num+t);
}

//k当前列 num第一行翻转的次数
void todfs(int k,int num)
{
	if(k>m)
	{
		dfs(2,num);//对第一行每种情况进行搜索 
		return;
	}
	f[1][k]=0;//不翻转 
	todfs(k+1,num);
	f[1][k]=1;//翻转 num+1 
	todfs(k+1,num+1);
}

int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)//下标从1开始便于边界处理 
	{
		for(int j=1;j<=m;j++) 
		{
			scanf("%d",&mp[i][j]);
		}
	}
	todfs(1,0);//递归遍历第一行所有情况 
	if(minn==0x1f1ffff) printf("IMPOSSIBLE\n");
	else
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				printf("%d ",ans[i][j]);
			}
			printf("\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/UncleJokerly/article/details/83350989