HDU - 1520 Anniversary party (树形dp)

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

 

7

1

1

1

1

1

1

1

1  3

2  3

6  4

7  4

4  5

3  5

0  0

Sample Output

 

5

题目大意: 一棵树,相邻的双亲和孩子节点不能同时选,每一个节点有一个权值,选出若干个节点,权值之和最大并输出

解题思路:树形dp,

dp[i][0]:当前节点不选时,以该节点为根的树所选节点的最大权值之和 

dp[i][1]:当前节点选时,以该节点为根的树所选节点的最大权值之和

AC代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=6e3+10;
int value[maxn],dp[maxn][2],degree[maxn];
int head[maxn],cnt;
struct node{
	int u;
	int to;
	int next;
}edge[maxn];
void add(int u,int v)
{
	edge[cnt].u=u;
	edge[cnt].to=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void dfs(int u,int pre)
{
	int ans0=0;//选当前节点u时,子树选的节点的最大权值之和 
	int ans1=0;//未选当前节点u时,子树选的节点的最大权值之和 
	for(int i=head[u];~i;i=edge[i].next)
	{
		int to=edge[i].to;
		if(to!=pre)
		{
			dfs(to,u);
		}
		ans0+=max(dp[to][0],dp[to][1]);
		ans1+=dp[to][0];
	}
	dp[u][0]=ans0;//当前节点不选时,以该节点为根的树所选节点的最大权值之和 
	dp[u][1]=ans1+value[u];//当前节点选中,以该节点为根的树所选节点的最大权值之和 
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		memset(head,-1,sizeof(head));
		memset(degree,0,sizeof(degree));
		cnt=0;
		for(int i=1;i<=n;i++)
			scanf("%d",&value[i]);
		int L,k;
		while(scanf("%d%d",&L,&k),L+k)
		{
			add(k,L); 
			degree[L]++;
		} 
		memset(dp,0,sizeof(dp));
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			if(degree[i]==0)
			{
				dfs(i,-1);
				ans+=max(dp[i][0],dp[i][1]);
			}
		}
		printf("%d\n",ans); 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/87993842