ZOJ - 3471 Most Powerful

题目:
Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.
You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, … , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.
The last case is followed by a 0 in one line.
There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22
代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
int a[12][12];
int dp[1 << 12];//这里用1代表原子消失,0代表原子存在,所有原子的状态构成二进制数 
int main()
{
	int n,ans;
	while(~scanf("%d",&n) && n){
		for(int i = 0;i < n;i++)
			for(int j = 0;j < n;j++)
				cin >> a[i][j];
		 for(int i = 0;i < (1 << n);i++) dp[i] = 0;
		 for(int i = 0;i < (1 << n);i++){
		 	for(int j = 0;j < n;j++){
		 		if(i & (1 << j)) continue;//代表j原子已经消失,不必再计算
				 for(int k = 0;k < n;k++){
				 	if(i & (1 << k)) continue;//k原子消失或者k原子等于j原子时跳过 
				 	if(j == k) continue; 
				 	dp[i | (1 << k)] = max(dp[i | (1 << k)],dp[i] + a[j][k]); 
				 } 
			 }
		 } 
		 ans = 0;
		 for(int i = 0;i < (1 << n);i++) ans = max(ans,dp[i]);
		 cout << ans << endl;
	}
	return 0;
} 

题意:
告诉有n个原子,随后输入n*n行第i行第j列代表i原子和j原子相撞,j原子消失后产生的能量。然后要求求还剩1个原子时爆炸产生的最大能量。
思路:
如果原子存在用0表示,消失用1表示。dp[i]代表所有原子目前的状态所能产生最大的能量。
现在来解释一下状态转移方程:dp[i | (1 << k)] = max(dp[i | (1 << k)],dp[i] + a[j][k]);
dp[i | (1 << k)]表示k点还存在的状态,然后让你比较j点和k点相撞k点消失的能量大还是k点存在时能量大。
最后找出所有状态中能量最大的那个。

猜你喜欢

转载自blog.csdn.net/qq_41998938/article/details/88695070
ZOJ