ZOJ 3471 Most Powerful (状态压缩)

版权声明:From: http://blog.csdn.net/tju_tahara https://blog.csdn.net/TJU_Tahara/article/details/76420809

Most Powerful

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


Author:  GAO, Yuan
Contest:  ZOJ Monthly, February 2011


题意:

和旅行商问题类似,每次挑选两个原子, 碰撞后产生能量,一个消失。问最多得到的能量。

思路:

简单的状态压缩……至今不知道为什么二维数组的状态压缩会WA。。可能我写的有毒。



#include <cstdio>
#include <iostream>
#include <cstring>
#define MAX 1000100

int dp[2100];
int map[12][12];

using std::max;

int main()
{
	int num, top, i, j, k, l;
	while(~scanf("%d", &num) && num){
		
		for(i = 1; i <= num; i++)
			for(j = 1; j <= num; j++)
				scanf("%d", &map[i][j]);
		top = (1 << num);
		memset(dp, 0, sizeof(dp));
		int res = 0;
		for(j = 0; j < top; j++)
			for(k = 0; k < num; k++){
				if(j & (1 << k)) continue;
				for(l = 0; l < num; l++){
					if(k == l) continue;
					if(j & (1 << l)) continue;
					dp[j | (1 << l)] = max(dp[j | (1 << l)], dp[j] + map[k + 1][l + 1]);
					if(dp[j | (1 << l)] > res)  res = dp[j | (1 << l)];
				}
			}

		printf("%d\n", res);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/TJU_Tahara/article/details/76420809
ZOJ