杭电2001------计算两点间的距离C++版

计算两点间的距离
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 300332 Accepted Submission(s): 103271
Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
Output
对于每组输入数据,输出一行,结果保留两位小数。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
Author
lcy
Source
C语言程序设计练习(一)

#include<iostream>
using namespace std;
#include<cmath>
#include<iomanip>
int main()
{
    double a,b,x,y;
    double d;
    while(cin>>a>>b>>x>>y)
    {
        d=sqrt(pow(a-x,2)+pow(b-y,2));
        cout<<fixed<<setprecision(2)<<d<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43289087/article/details/88580384