HDU2001.计算两点间的距离

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=2001

题目:

Problem Description

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

 

Input

输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

 

Output

对于每组输入数据,输出一行,结果保留两位小数。

 

Sample Input

 

0 0 0 1 0 1 1 0

 

Sample Output

 

1.00 1.41

代码:

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    double x1,x2,y1,y2;
    while(cin>>x1>>y1>>x2>>y2){
        double sum=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
        printf("%.2lf\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Zero_979/article/details/81281279