2001:计算两点间的距离

Description

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input

输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

Output

对于每组输入数据,输出一行,结果保留两位小数。

Sample Input

 
   
0 0 0 1
0 1 1 0

Sample Output

 
   
1.00
1.41

#include<iostream>
#include<math.h>
#include<iomanip>  //输入输出流操作头文件 
                   //用setprecision(n)设置精度,其中n表示精确到小数点后n位 
using namespace std;
float distance(float a,float b,float c,float d){  //函数说明在前,调用在后 
	return sqrt((a-c)*(a-c)+(b-d)*(b-d));
}
int main(){
	float x1,y1,x2,y2;
	float result; 
	while(cin>>x1>>y1>>x2>>y2){     //输入为空时,终止while循环
		result=distance(x1,y1,x2,y2);
		cout<<fixed<<setprecision(2)<<result<<endl;//注意这里要换行,否则格式错误
	}
	return 0;
} 

注意:究竟如何终止while()循环!!!

猜你喜欢

转载自blog.csdn.net/gunianshan/article/details/81013887
今日推荐