1147 Heaps (30 分)完全二叉树的建树,判断堆

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题意:

         给出一个完全二叉树,判断是不是堆,是什么堆,输出其后序遍历

思路:
        根据完全二叉树的性质   父x 左x*2 右x*2+1 建树,判断堆,直接利用层序数组里 level[i] 大于还是小于 level[2*i] 与 level[2*i+1],在后序遍历

#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=10005;
int level[maxn];
int m,n;
vector<int>ans;
struct node
{
	int data;
	node *lchild,*rchild;
};
node *build(int x)//1号位开始 
{
	if(x>n)
	return NULL;
	node *root=new node;
	root->data=level[x];
	root->lchild=NULL;
	root->rchild=NULL;
	if(x*2<=n)
	root->lchild=build(x*2);
	if(x*2+1<=n)
	root->rchild=build(x*2+1);
	return root;
}
void postorder(node *root)
{
	if(root==NULL)
	return;
	postorder(root->lchild);
	postorder(root->rchild);
	ans.push_back(root->data);
}	
bool maxheap()
{
	for(int i=1;i<=n;i++)
	{
		if(level[i]<level[i*2]&&i*2<=n)
		return false;
		if(level[i]<level[i*2+1]&&(i*2+1)<=n)
		return false;
	}
	return true;
} 
bool minheap()
{
	for(int i=1;i<=n;i++)
	{
		if(level[i]>level[i*2]&&i*2<=n)
		return false;
		if(level[i]>level[i*2+1]&&(i*2+1)<=n)
		return false;
	}
	return true;
}
int main()
{
	scanf("%d%d",&m,&n);
	while(m--)
	{
		memset(level,0,sizeof(level));//初始化
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&level[i]);
		} 
		//完全二叉树建树 
		node *root=build(1);
		//判断是否为堆
		if(maxheap())
		printf("Max Heap\n");
		else if(minheap())
		printf("Min Heap\n");
		else
		printf("Not Heap\n");
		//输出后序 
		postorder(root);
		for(int i=0;i<ans.size();i++)
		{
			printf("%d",ans[i]);
			if(i<ans.size()-1)
			printf(" ");
			else
			printf("\n");
		} 
		ans.clear();
	}
} 

猜你喜欢

转载自blog.csdn.net/qq_40916491/article/details/88056604
今日推荐