1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

判断二叉树是不是大顶堆,小顶堆或者不是堆,按照二叉树的层序输入。

#include<bits/stdc++.h>
using namespace std;
int n,m;
vector<int>v;
void postorder(int index)
{
    if(index>n)
        return ;
    postorder(index*2);
    postorder(index*2+1);
    if(index!=1)
        cout<<v[index]<<" ";
}

int main()
{
    cin>>m>>n;
    v.resize(n+1);
    for(int i=0;i<m;i++)
    {
        int ismin=1,ismax=1;
        for(int j=1;j<=n;j++)
            cin>>v[j];
        for(int j=2;j<=n;j++)
        {
            if(v[j/2]>v[j])
                ismin=0;
            if(v[j/2]<v[j])
                ismax=0;
        }
        if(ismin==1)
            cout<<"Min Heap"<<endl;
        else
        {
            if(ismax==1)
                cout<<"Max Heap"<<endl;
            else
                cout<<"Not Heap"<<endl;
        }
        postorder(1);
        cout<<v[1]<<endl;
    }
}
 

猜你喜欢

转载自blog.csdn.net/x_zjudream/article/details/86508773