1147 Heaps(30 分)(C++)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

给定一个完全二叉树的层次遍历,判断该树是否为大顶堆或者小顶堆,同时写出该完全二叉树的后序排列

分为两步:

1、由完全二叉树的层次遍历得出其后序遍历

2、判断大顶堆还是小顶堆

均为DFS

#include <string>
#include <iostream>
#include <vector>
using namespace std;
int m,n;
std::vector<int> level,post;
bool result;
void posttravel(int root){
    if(root>n)
        return;
    posttravel(2*root);
    posttravel(2*root+1);
    post.push_back(level[root]);
}
void dfs(bool flag,int root,int index){
    if(flag==true){
        if(index>n)
            return;
        if(root<level[index])
            result=false;
        dfs(flag,level[index],2*index);
        dfs(flag,level[index],2*index+1);
    }
    else{
        if(index>n)
            return;
        if(root>level[index])
            result=false;
        dfs(flag,level[index],2*index);
        dfs(flag,level[index],2*index+1);
    }
}
int main(){
    scanf("%d %d",&m,&n);
    level.resize(n+1);
    for(int i=0;i<m;i++){
        for(int j=1;j<=n;j++)
            scanf("%d",&level[j]);
        result=true;
		post.clear();
        posttravel(1);
        dfs(true,level[1],1);
        if(result==true)
            cout<<"Max Heap\n";
        else{
            result=true;
            dfs(false,level[1],1);
            if(result==true)
                cout<<"Min Heap\n";
            else
                cout<<"Not Heap\n";
        }
        printf("%d",post[0]);
        for(int i=1;i<n;i++)
            printf(" %d",post[i]);
		printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82526012