PAT A1100 Mars Numbers+map初探

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

代码如下:

#include <map>
#include <string>

using namespace std;
map<string,int> string2int;
const int maxn=25;
string s[maxn]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
void init(){
    for(int i=0;i<13;i++){
        string2int[s[i]]=i;
    }
    for(int i=13;i<maxn;i++){
        string2int[s[i]]=(i-12)*13;
    }
}
void earth(string num){
    int num10=0;
    for(int i=0;i<num.size();i++){
        num10=10*num10+num[i]-'0';
    }
    int l=num10%13;
    int h=num10/13;
    string ans;
    if(h>0){
        ans=s[h+12];
        if(l>0){ //如果是13的倍数,不用输出tret
            ans+=" ";
            ans+=s[l];
        }
    }else{
        ans=s[l];
    }
    cout << ans << endl;
}

void mar(string num){
    if(num.size()<=4){
        cout << string2int[num] << endl;
    }else{
        int pos=num.find(" ");
        int ans=string2int[num.substr(0,pos)]+string2int[num.substr(pos+1,num.size()-pos-1)];
        cout << ans << endl;
    }
}


int main()
{
    init();
    int n;
    cin >> n;
    string num;
    getchar();
    for(int i=0;i<n;i++){
        getline(cin,num);
        if(num[0]<='9' && num[0]>='0'){ //阿拉伯数字
            earth(num);
        }
        else{
            mar(num);
        }
    }
    return 0;
}

 注:一开始有两个测试点过不去的原因是:13的倍数如13,应该输出tam,而不是tam tret

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/88378457