九度OJ题目1036:Old Bill

题目描述:
    Among grandfather's papers a bill was found.
    72 turkeys $_679_
    The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?
    We want to write a program that solves a general version of the above problem.
    N turkeys $_XYZ_
    The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an integer number of dollars, and that all the turkeys cost the same price.
    Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded digits and the maximum price per turkey for the turkeys.

输入:
    The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

输出:
    For each case, output the two faded digits and the maximum price per turkey for the turkeys.

样例输入:
72
6 7 9
5
2 3 7
78
0 0 5
样例输出:
3 2 511
9 5 18475
0
来源:
2007年上海交通大学计算机研究生机试真题

#include<stdio.h>
int main() {
	int n;
	int x, y, z;
	while (scanf("%d", &n) != EOF) {
		int max = 0;
		scanf("%d%d%d", &x, &y, &z);
		for (int i = 1; i <= 9; i++) {
			for (int j = 0; j <= 9; j++) {
				int tmp = (10000 * i + x * 1000 + y * 100 + z * 10 + j)%n;
				int tmp2 = (10000 * i + x * 1000 + y * 100 + z * 10 + j) / n;
					if(tmp==0){
						if (tmp2 > max) {
							max = tmp2;
						}
						printf("%d %d ", i, j);//输出缺失的两位数
				}
			}
		}
		printf("%d\n", max);//输出最大单价
	}
	return 0;
}


 

猜你喜欢

转载自blog.csdn.net/sinat_38292108/article/details/87618270