算法笔记课后习题 codeup6.4map 问题 A: Speech Patterns (25)

版权声明:原创文章,转载请注明出处 https://blog.csdn.net/hza419763578/article/details/88371787

问题 A: Speech Patterns (25)

时间限制: 1 Sec  内存限制: 32 MB
提交: 397  解决: 124
[提交][状态][讨论版][命题人:外部导入]

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

输入

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: "Can a can can a can?  It can!"

样例输出

can 5

不需要傻傻去截取“”内的字符串

#include<iostream>
#include<string>
#include<map>
using namespace std;
int main(){
	string s;
	map<string,int> mp;
	map<string,bool> mbool;
	while(getline(cin,s)){
		// int m=s.find("\"");
		// s=s.substr(m+1,s.length()-1-(m+1));
		char a[100],index=0;
		mp.clear();	
		for(int i=0;i<=s.length();i++){//加上等号 反正\0也是特殊字符 这样防止最后一个字符没判断
			if(isalnum(s[i])){
				if(isupper(s[i])) s[i]+=32;
				a[index++]=s[i];
			}else{
				if(index==0) continue;
				a[index]='\0';
				index=0;
				string key=a;
				if(mp.find(key)!=mp.end()){
					mp[key]++;
				}else{
					mp[key]=1;
				}
			}
		}
		int max=0;
		string maxstring;
		for(map<string,int>::iterator it=mp.begin();it!=mp.end();it++){
			if(it->second>max){
				max=it->second;
				maxstring=it->first;
			}
		}
		cout<<maxstring<<" "<<max<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hza419763578/article/details/88371787
今日推荐