A1071 Speech Patterns (25 分)

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题意:

 令“单词”的定义为大小写字母、数字的组合。给出一个字符串no more than 1048576 characters,问出现次数最多的单词及其出现次数(一切除了大小写字母、数字之外的字符都作为单词的分隔符)。其中字母不区分大小写,且最后按小写字母输出。

思路:

采用 map 存储出现的单词。分为两步:从给定字符串中分割出“单词”, 计数记录出现最多次的单词

  1. 单词由大小写字母和数字组成,我们先成为有效字符。因此枚举给定字符串中的每一个字符,如果为有效字符,将其加入当前单词当中(如果是大写字母,转换为小写);如果不是有效,当前单词的出现次数加一,跳过该字符。进行下一个单词的组合。
  2. 遍历 map 中的所有元素,找出最大

注意:

  1. 不区分大小写:把大写字母转换为小写,存储即可实现
  2. 在得到一个单词之后,必须先查看 map 中是否存在该单词。如果不存在,则不能直接对其加一,而应直接将其出现次数赋值为1
  3. str[i] += 32;  将大写字母转换为小写字母
#include <iostream>
#include <string>
#include <map>
using namespace std;
bool check(char c){
  if(c >= '0' && c <= '9')
    return true;
  if(c >= 'A' && c <= 'Z')
    return true;
  if(c >= 'a' && c <= 'z')
    return true;
  return false;
}
int main(){
  map<string, int> count;
  string str;
  getline(cin, str);
  int i = 0;
  while(i < str.length()){
    string word;
    while(i < str.length() && check(str[i]) == true){
      if(str[i] >= 'A' && str[i] <= 'Z'){
        str[i] += 32;   
      }
      word += str[i];
      i++;
    }
    if(word != ""){
      if(count.find(word) == count.end())
        count[word] = 1;
      else
        count[word]++;
    }
    while(i < str.length() && check(str[i]) == false){
      i++;
    }
  }
  string ans;
  int max = 0;
  for(map<string, int>::iterator it = count.begin(); it != count.end(); it++){
    if(it -> second > max){
      max = it -> second;
      ans = it -> first;
    }
  }
  cout << ans << " " << max << endl;
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/87799353
今日推荐