poj3104 二分

Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20920   Accepted: 5265

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

Source

Northeastern Europe 2005, Northern Subregion
二分时间,看是否合适,如果符合,r=mid-1,继续找最小的,如果不符合,l=mid+1,找大的,这里要注意一下,吹风机的时候,是不会自然风干的,也就是说,如果吹风机一分钟吹干k,那么它在那一秒是没有自然风干的,我们是先假设它自然风干了mid,那么如果它还没干,那么就要用吹风机去吹,c=a[i]-mid,这是自然风干后的值,假设我们需要m秒去吹干它,c-mk+m=0
这里mk就是吹风机吹干的水,+m代表着这里m秒没有被自然风干,所以加上它,求出m,取上界,就可以得出答案了,注意还有k=1的情况,k=1的情况证明k是没有任何用处的,只能让他自然风干,就相当于c-m+m=0其实是不存在的,所以直接不符合就好了
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;
int n;
long long k;
long long a[100009];
int cmp(long long a,long long b)
{
    return a>b;
}
int solve(long long mid)
{
    long long c;
    int i;
    long long ans=0;
    for(i=0; i<=n-1; i++)
    {
        c=a[i]-mid;
        if(c<=0) continue;
        if(k==1) return 0;
        long long l=ceil(c*1.0/(k-1));
        ans+=l;
        if(ans>mid) break;
    }
    if(ans>mid) return 0;
    else return 1;
}
int main()
{
    int i;
    while(~scanf("%d",&n))
    {
        long long C=0;
        for(i=0; i<=n-1; i++)
        {
            scanf("%lld",&a[i]);
        }
        scanf("%lld",&k);
        sort(a,a+n,cmp);
        long long l=1,r=1000000009,mid;
        while(l<=r)
        {
            mid=(l+r)/2;
            if(solve(mid))
            {
                C=mid;
                r=mid-1;
            }
            else l=mid+1;
        }
        printf("%lld\n",C);
    }
}
/*
3
2 3 9
5
3
2 3 6
5
*/


猜你喜欢

转载自blog.csdn.net/keepcoral/article/details/80059519