(java)杭电acm 题号:1001 Sum Problem

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/King296316960/article/details/74502343

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 479541    Accepted Submission(s): 121267


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
 
  
1 100
 

Sample Output
 
  
1

5050

package acm;

import java.util.Scanner;

/**
 *
 * @author 
 */
public class Main {

    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        while (input.hasNext()) {
            int A = 1;
            int S = 0;
            int n = input.nextInt();
            while (A <= n) {
                S = S + A;
                A++;
            }
            System.out.println(S);
            System.out.println("");
        }
    }

}

猜你喜欢

转载自blog.csdn.net/King296316960/article/details/74502343