F - Circular Sequence

Problem Description

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence CGAGTCAGCT", that is, the last symbolT" in CGAGTCAGCT" is connected to the first symbolC". We always read a circular sequence in the clockwise direction.


Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, A, C, G and T, are allowed. Each sequence has length at least 2 and at most 100.

Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

The following shows sample input and output for two test cases.

Sample Input

2
CGAGTCAGCT
CTCC

Sample Output

AGCTCGAGTC
CCCT

#include <bits/stdc++.h>
#include<stdio.h>
using namespace std;
char a[105];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int ans=0;  //表示以ans为头的字典序最小的字符串
        scanf("%s",&a);
        for(int i=1;i<strlen(a);i++){      //依次遍历以i为头的字符串
            for(int j=0;j<strlen(a);j++){
                if(a[(i+j)%strlen(a)]!=a[(j+ans)%strlen(a)]){         //如果不相等
                    if(a[(i+j)%strlen(a)]<a[(j+ans)%strlen(a)])ans=i;  //返回最小的那个
                    else break;
                }
            }
        }
        for(int i=0;i<strlen(a);i++)
            printf("%c",a[(i+ans)%strlen(a)]);  //输出
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43328040/article/details/88367374
今日推荐