c 整数解

Problem Description
有二个整数,它们加起来等于某个整数,乘起来又等于另一个整数,它们到底是真还是假,也就是这种整数到底存不存在,实在有点吃不准,你能快速回答吗?看来只能通过编程。
例如:
x + y = 9,x * y = 15 ? 找不到这样的整数x和y
1+4=5,14=4,所以,加起来等于5,乘起来等于4的二个整数为1和4
7+(-8)=-1,7
(-8)=-56,所以,加起来等于-1,乘起来等于-56的二个整数为7和-8

Input
输入数据为成对出现的整数n,m(-10000<n,m<10000),它们分别表示整数的和与积,如果两者都为0,则输入结束。

Output
只需要对于每个n和m,输出“Yes”或者“No”,明确有还是没有这种整数就行了。

Sample Input
9 15
5 4
1 -56
0 0

Sample Output
No
Yes
Yes

代码:

#include<stdio.h>
void main()
{
	int i,n,m;
	while(~scanf("%d %d",&n,&m)){
		if(m==0&&n==0){
		    break;
		}
		for(i=10000;i>-10000;i--){
			if(i*(n-i)==m){
				printf("Yes\n");
			    break;
			}
		}
		if(i==-10000){
		    printf("No\n");
		}
	}
}




猜你喜欢

转载自blog.csdn.net/qq_40811682/article/details/88253198