【ZOJ 2968】Difference Game

Now you are going to play an interesting game. In this game, you are given two groups of distinct integers and C coins. The two groups, named Ga and Gb respectively, are not empty and contain the same number of integers at first. Each time you can move one integer in one group to the other group. But a move that makes a group empty is considered as invalid. Each move will cost you p coins, and p equals the difference of the size between the two group (take the absolute value. e.g. moving a number from the group of size 4 to the group of size 6 will cost you |4 - 6| = 2 coins, and moving a number between two group with same size will not cost any coins). You can do as many moves as you wish, so long as the total cost does not exceed C.

Let M be the minimum integer in Ga, and N be the maximum integer in Gb. The purpose of this game is to produce a maximum (M - N).

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 60) which is the number of test cases. And it will be followed by T consecutive test cases.

Each case begin with two integers S (1 <= S <= 20000, indicating the size of Ga and Gb at first) and C (0 <= C <= 1000000). Two lines of S integers follow, representing the numbers in Ga and Gb respectively. All these integers are distinct and are between 1 and 50000, both inclusive.

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the maximum possible value for M - N after some moves.

Sample Input

2
1 10
10
12
2 10
1 2
3 4

Sample Output

扫描二维码关注公众号,回复: 5424863 查看本文章
-2
1

Hint

For Sample 1, two groups are of size 1, so no moves can be done because any moving will make Ga or Gb empty, which is not valid. So M = 10, N = 12, M - N = -2.
For Sample 2, one valid steps of moves is:
Move 1 in Ga to Gb, cost 0 coins.
Move 3 in Gb to Ga, cost 2 coins.
Move 4 in Gb to Ga, cost 0 coins.
Then Ga contains 2 3 4, Gb contains 1, M = 2, N = 1, M - N = 1. This is the maximum possible value.

题意:

两个容器a、b,各装有s个数,所有数字都不相同。有c个硬币。每次可以花费两容器数字个数之差(abs(a.size()-b.size())的硬币,把数从一个容器移动到另一个容器里。

求a中数字的最小值减b中数字的最大值。

思路:

两种情况。

  1. 答案为正数。对2s个数排序,最终结果肯定是某一个间隔值。另a容器放置最大的i个数,b容器放置剩下的数,枚举i。设aa为a往b中移动的数字个数,bb为b往a中移动的数字个数,则花费cost=min(aa,bb)*2+abs(bb-aa)*(abs(bb-aa)-1)。因为移动时先以互换的方式(0 2 0 2.......)的移动,最后多出来的一部分再移动过去。只要cost<=c,就跟之前求的答案取个最大值就好了。
  2. 答案为负数。给a,b中的数分别排序。以互换的方式(0 2 0 2.......)进行移动。最后可以某个容器多移动一次,消耗0。a多移动一次和b多移动一次取个最大值。

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=4e4+100;
int a[N],b[N];
struct node{
	int v;
	int type;
}mp[N];
bool cmp(node a,node b){
	return a.v>b.v;
}
int main(){
	int t,s,c,x,maxx,aa,bb,flag,num;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&s,&c);
		for(int i=0;i<s;++i){
			scanf("%d",&a[i]);
			mp[i].v=a[i];
			mp[i].type=1;
		}
		for(int i=0;i<s;++i){
			scanf("%d",&b[i]);
			mp[i+s].v=b[i];
			mp[i+s].type=2;
		}
		sort(a,a+s);
		sort(b,b+s);
		sort(mp,mp+s+s,cmp);
		maxx=a[0]-b[s-1];
		flag=0;
		if(s>1){
			x=c/2;
			num=0;			
			for(int i=0;i<s+s-1;++i){
				if(mp[i].type==1)num++;
				aa=s-num;
				bb=i+1-num;
				if(min(aa,bb)*2+abs(bb-aa)*(abs(bb-aa)-1)<=c)
					maxx=max(maxx,mp[i].v-mp[i+1].v),flag=1;
			}
			if(flag==0)maxx=max(maxx,max(a[x+1]-b[s-1-x],a[x]-b[s-1-(x+1)]));
		}
		printf("%d\n",maxx);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/aiyouyou_/article/details/88175176