Invitation Cards POJ - 1511 双向单源最短路径(SPFA+vector存图)

  • Invitation Cards

题目链接:http://poj.org/problem?id=1511

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题意:求点1到其他n-1个点的往返最短路之和

思路:此题和POJ - 3268相似都是定点到其他的往返最短路,只是此题多了求和,所以注意数据类型大小。此题相当于求两次以点1为起点的最短路。这题数据量有点大,用了vector来存图,一开始定义了两个vector结果超时了,换成一个vector再用三个数组记录前面输入的边就过了。

AC代码:

4875ms

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
#define ll long long
const int INF = 0x3f3f3f3f;
const int MAXN = 1000000 + 5;
using namespace std;
int n, m;
struct edge {
	int end;
	int cost;
};
vector<edge>map[MAXN]; 
int x[MAXN], y[MAXN], z[MAXN];
ll dist[MAXN];
void SPFA(vector<edge>mapn[]);
int main()
{
	int t;
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &n, &m); 
		for (int i = 1; i <= n; ++i) {
			map[i].clear();
		}
		for (int i = 1; i <= m; ++i) {
			edge e;
			scanf("%d%d%d", &x[i], &y[i], &z[i]);
			e.end = y[i];
			e.cost = z[i];
			map[x[i]].push_back(e);
		}
		ll ans = 0;
		SPFA(map);
		for (int i = 1; i <= n; ++i) {
			ans += dist[i];
		}
		for (int i = 1; i <= n; ++i) {
			map[i].clear();
		}
		for (int i = 1; i <= m; ++i) {
			edge e;
			e.end = x[i];
			e.cost = z[i];
			map[y[i]].push_back(e);
		}
		SPFA(map);
		for (int i = 1; i <= n; ++i) {
			ans += dist[i];
		}
		printf("%lld\n", ans);
	}
}

void SPFA(vector<edge>mapn[]){
	queue<int> q;
	for (int i = 1; i <= n; ++i) {
		dist[i] = INF;
	}
	dist[1] = 0;
	q.push(1);
	while (!q.empty()) {
		int u = q.front();
		q.pop();
		for (int i = 0; i < mapn[u].size(); ++i) {
			if (dist[mapn[u][i].end] > dist[u] + mapn[u][i].cost) {
				dist[mapn[u][i].end] = dist[u] + mapn[u][i].cost;
				q.push(mapn[u][i].end);
			}
		}
	}
}

相似题型:poj-3268 

                  https://blog.csdn.net/weixin_43821265/article/details/86594102 

猜你喜欢

转载自blog.csdn.net/weixin_43821265/article/details/86689828