Drainage Ditches HDU - 1532 网络流 (最大流 Edmonds-Karp算法)

  • Drainage Ditches

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1532

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch. 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

题意:求源点到汇点的最大流。

思路:网络最大流基础模板题。

刚学网络流,建图上没有把同一条路的流量相加,wa了也不知道错在哪。

AC代码:
62ms

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
const int INF = 0x7fffffff;
const int MAXN = 1e5 + 7;
using namespace std;
int visit[MAXN];
int pre[MAXN];
int n, m;
int map[1010][1010];
void update_residual_network(int u, int flow);
int bfs(int s, int t);
int edmonds_karp(int s, int t);
int main()
{
	while (~scanf("%d%d", &n, &m)) {
		memset(map, 0, sizeof(map));
		for (int i = 1; i <= n; ++i) {
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			map[a][b] += c;
		}
		printf("%d\n", edmonds_karp(1, m));
	}
	return 0;
}

void update_residual_network(int u, int flow) {
	while (pre[u] != -1) {
		map[pre[u]][u] -= flow;
		map[u][pre[u]] += flow;
		u = pre[u];
	}
}

int bfs(int s, int t) {
	memset(visit, 0, sizeof(visit));
	memset(pre, -1, sizeof(pre));
	visit[s] = 1;
	int minn = INF;
	queue<int >q;
	q.push(s);
	while (!q.empty()) {
		int cur = q.front();
		q.pop();
		if (cur == t)
			break;
		for (int i = 1; i <= m; ++i) {
			if (!visit[i] && map[cur][i]) {
				q.push(i);
				minn = min(minn, map[cur][i]);
				pre[i] = cur;
				visit[i] = 1;
			}
		}
	}
	if (pre[t] == -1)
		return 0;
	return minn;
}

int edmonds_karp(int s, int t) {
	int new_flow = 0;
	int max_flow = 0;
	do {
		new_flow = bfs(s, t);
		update_residual_network(t, new_flow);
		max_flow += new_flow;
	} while (new_flow);
	return max_flow;
}

猜你喜欢

转载自blog.csdn.net/weixin_43821265/article/details/86912638