Drainage Ditches HDU - 1532 最大流 模板

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50


1.Ford--Fulkerson算法


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int M = 1e5 + 10;
//表示边的结构体(终点,容量,反向边)
struct node
{
    int to;ll cap;
    int rev;
};
int n,m;
vector<node>no[1000];
bool vis[1000];
//向图增加一条从s到t容量为cap的边
void init(int from,int to,ll cap)
{
    no[from].push_back((node){to,cap,no[to].size()});
    no[to].push_back((node){from,0,no[from].size()-1});
}
ll dfs(int v,int t,ll f)
{
    if(v==t)
        return f;
    vis[v]=1;
    for(int i=0;i<no[v].size();i++)
    {
        node &e=no[v][i];
        if(!vis[e.to]&&e.cap>0)
        {
            ll d=dfs(e.to,t,min(f,e.cap));
            if(d>0)
            {
                e.cap-=d;
                no[e.to][e.rev].cap+=d;
                return d;
            }
        }
    }
    return 0;
}
//求解S到T的最大流
ll max_flow(int s,int t)
{
    ll ff=0;
    for(;;)
    {
        memset(vis,0,sizeof(vis));
        ll f=dfs(s,t,inf);
        if(f==0)
            return ff;
        ff+=f;
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(no,0,sizeof(no));
        int fr,to; ll c;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%lld",&fr,&to,&c);
            init(fr,to,c);
        }
        ll ans=max_flow(1,m);
        printf("%lld\n",ans);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/liluoyu_1016/article/details/80000325
今日推荐