week11_

Generating permutation has always been an important problem in computer science. In this problem you will have to generate the permutation of a given string in ascending order. Remember that your algorithm must be efficient.

Input

The first line of the input contains an integer n, which indicates how many strings to follow. The next n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The maximum length of the string is 10.

Output

For each input string print all the permutations possible in ascending order. Not that the strings should be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow each output set.

Sample Input

3

ab

abc

bca

Sample Output

ab

ba

abc

acb

bac

bca

cab

cba

abc

acb

bac

bca

cab

cba

核心思想:全排列 

知识要求:prev_permutation(S,S+Len);next_prepermutation(S,S+Len)函数

sort()函数

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n;
//bool cmp2(char a,char b){
//	return a>b;
//}从大到小排序

bool cmp1(char a,char b){
	return a<b;
} //从小到大排序 
int main()
{
	int t,i,j,k,q,tmp;
	int N=10;//总的个数 
    scanf("%d\n",&n);
    char s[N+1];
    
	while(n--)
	{
		gets(s);
		sort(s,s+strlen(s),cmp1);
//字典排序,从小到大,cmp1:next_permutation(S,S+Len);cmp2,从大到小,
//prev_permutation(S,S+Len) 
		do{
			puts(s);
		}while(next_permutation(s,s+strlen(s)));
		printf("\n");
}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43442778/article/details/84574433