双联通缩点+二分图

Being a knight is a very attractive career: searching for the Holy Grail, saving damsels in distress, and drinking with the other knights are fun things to do. Therefore, it is not very surprising that in recent years the kingdom of King Arthur has experienced an unprecedented increase in the number of knights. There are so many knights now, that it is very rare that every Knight of the Round Table can come at the same time to Camelot and sit around the round table; usually only a small group of the knights isthere, while the rest are busy doing heroic deeds around the country. 

Knights can easily get over-excited during discussions-especially after a couple of drinks. After some unfortunate accidents, King Arthur asked the famous wizard Merlin to make sure that in the future no fights break out between the knights. After studying the problem carefully, Merlin realized that the fights can only be prevented if the knights are seated according to the following two rules:

  • The knights should be seated such that two knights who hate each other should not be neighbors at the table. (Merlin has a list that says who hates whom.) The knights are sitting around a roundtable, thus every knight has exactly two neighbors.
  • An odd number of knights should sit around the table. This ensures that if the knights cannot agree on something, then they can settle the issue by voting. (If the number of knights is even, then itcan happen that ``yes" and ``no" have the same number of votes, and the argument goes on.)

Merlin will let the knights sit down only if these two rules are satisfied, otherwise he cancels the meeting. (If only one knight shows up, then the meeting is canceled as well, as one person cannot sit around a table.) Merlin realized that this means that there can be knights who cannot be part of any seating arrangements that respect these rules, and these knights will never be able to sit at the Round Table (one such case is if a knight hates every other knight, but there are many other possible reasons). If a knight cannot sit at the Round Table, then he cannot be a member of the Knights of the Round Table and must be expelled from the order. These knights have to be transferred to a less-prestigious order, such as the Knights of the Square Table, the Knights of the Octagonal Table, or the Knights of the Banana-Shaped Table. To help Merlin, you have to write a program that will determine the number of knights that must be expelled. 

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers 1 ≤ n ≤ 1000 and 1 ≤ m ≤ 1000000 . The number n is the number of knights. The next m lines describe which knight hates which knight. Each of these m lines contains two integers k1 and k2 , which means that knight number k1 and knight number k2 hate each other (the numbers k1 and k2 are between 1 and n ). 

The input is terminated by a block with n = m = 0 . 
 

Output

For each test case you have to output a single integer on a separate line: the number of knights that have to be expelled. 
 

Sample Input

5 5
1 4
1 5
2 5
3 4
4 5
0 0

Sample Output

2

题目大意:有n个骑士经常举行圆桌会议,每次圆桌会议至少要有3个骑士参加(且每次参加的骑士数量是奇数个),且所有互相憎恨的骑士不能坐在圆桌旁的相邻位置,问有多少个骑士不可能参加任何一个会议

思路,首先根据给出的憎恨图得出补图,然后就是找出不能形成奇圈的点
利用下面二个定理:
1.如果一个双连通分量的某些顶点在一个奇圈中(即双连通分量含有奇圈),那么这个双连通分量的其他顶点也在这个奇圈中
2.如果一个双连通分量含有奇圈,那么他必然不是一个二分图,反过来也成立,这是一个充要条件

做法是对补图求出点双连通分量并缩点,使用染色法判断是不是二分图,不是二分图,这个双连通分量的点是可以存在的
代码

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<map>
#include<stack>
#include<set>
using namespace std;
#define LL long long
const int maxn = 1000 + 5;
struct Edge
{
    int u,v;
};
/*
bcc_cnt:多少个连通分量。
  bcc[i][j]=x:第i个双连通分量的第j个点是x;
  bccno[x]=i:x点在第i个双连通分量。
*/
int pre[maxn],iscut[maxn],bccno[maxn],dfs_clock,bcc_cnt;
vector<int> G[maxn],bcc[maxn];
stack<Edge> S;
int dfs(int u,int fa)
{
    int lowu = pre[u] = ++dfs_clock;
    int child = 0;
    for(int i = 0; i < G[u].size(); i++)
    {
        int v = G[u][i];
        Edge e = (Edge)
        {
            u,v
        };
        if(!pre[v])
        {
            S.push(e);
            child++;
            int lowv = dfs(v,u);
            lowu = min(lowu, lowv);
            if(lowv >= pre[u])
            {
                iscut[u] = true;
                bcc_cnt++;
                bcc[bcc_cnt].clear();
                for(;;)
                {
                    Edge x = S.top();
                    S.pop();
                    if(bccno[x.u] != bcc_cnt)
                    {
                        bcc[bcc_cnt].push_back(x.u);
                        bccno[x.u] = bcc_cnt;
                    }
                    if(bccno[x.v] != bcc_cnt)
                    {
                        bcc[bcc_cnt].push_back(x.v);
                        bccno[x.v] = bcc_cnt;
                    }
                    if(x.u == u && x.v ==v)break;
                }
            }
        }
        else if(pre[v] < pre[u] && v != fa)
        {
            S.push(e);
            lowu = min(lowu, pre[v]);
        }
    }
    if(fa < 0 && child == 1)iscut[u] = 0;
    return lowu;
}

void find_bcc(int n)
{
    memset(pre,0,sizeof(pre));
    memset(iscut,0,sizeof(iscut));
    memset(bccno,0,sizeof(bccno));
    dfs_clock = bcc_cnt = 0;
    for(int i=0; i < n; i++)
    {
        if(!pre[i])dfs(i,-1);
    }
}

int odd[maxn],color[maxn];

bool bipartite(int u,int b)//判断编号为b的双联通分量是不是二分图
{
    for(int i = 0; i < G[u].size(); i++)
    {
        int v = G[u][i];
        if(bccno[v] != b)continue;
        if(color[v] == color[u])return false;
        if(!color[v])
        {
            color[v] = 3 - color[u];
            if(!bipartite(v,b))return false;
        }
    }
    return true;
}

int A[maxn][maxn];

int main()
{
    int iCase = 0, n, m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n == 0 && m == 0)break;
        for(int i = 0; i < n; i++)
        {
            G[i].clear();
        }
        memset(A,0,sizeof(A));
        for(int i = 0; i < m; i++)
        {
            int u, v;
            scanf("%d%d", &u, &v);
            u--;
            v--;
            A[u][v] = A[v][u] = 1;
        }
        for(int i = 0; i < n; i++)
        {
            for(int j = i+1; j < n; j++)
            {
                if(!A[i][j])
                {
                    G[i].push_back(j);
                    G[j].push_back(i);
                }
            }
        }
        find_bcc(n);
        memset(odd, 0, sizeof(odd));
        for(int i = 1; i <= bcc_cnt; i++)
        {
            memset(color, 0, sizeof(color));
            for(int j = 0; j < bcc[i].size(); j++)
            {
                bccno[bcc[i][j]] = i;
            }
            int u = bcc[i][0];
            color[u] = 1;
            if(!bipartite(u,i))
            {
                for(int j = 0; j < bcc[i].size(); j++)
                {
                    odd[bcc[i][j]] = 1;
                }
            }
        }
        int ans = n;
        for(int i = 0; i < n; i++)
        {
            if(odd[i])
            {
                ans--;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/87886495