poj 3177双连通分量+缩点(有重边)

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. 

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample: 

One visualization of the paths is: 

   1   2   3
   +---+---+  
       |   |
       |   |
 6 +---+---+ 4
      / 5
     / 
    / 
 7 +

Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 

   1   2   3
   +---+---+  
   :   |   |
   :   |   |
 6 +---+---+ 4
      / 5  :
     /     :
    /      :
 7 + - - - - 

Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7 
Every pair of fields is, in fact, connected by two routes. 

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1005
#define maxm 2005
using namespace std;
int n,m;
int dfsclock;
int cnt;
int head[maxn];
int low[maxn];
int dfn[maxn];
int degree[maxn];
struct edge
{
    int to,next;
}edges[maxm];
void init()
{
    cnt=0;
    dfsclock=0;
    memset(head,-1,sizeof(head));
    memset(degree,0,sizeof(degree));
    memset(dfn,0,sizeof(dfn));

}
void addedge(int u,int v)
{
    edges[cnt].next=head[u];
    edges[cnt].to=v;
    head[u]=cnt++;
}
void dfs(int u,int fa)
{
    low[u]=dfn[u]=++dfsclock;
    for(int i=head[u];i!=-1;i=edges[i].next)
    {
        int v=edges[i].to;
        if(i==(fa^1))
            continue;
        if(!dfn[v])
        {
            dfs(v,i);
            low[u]=min(low[u],low[v]);


        }
        else low[u]=min(low[u],dfn[v]);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            addedge(a,b);
            addedge(b,a);
        }
        dfs(1,-1);
        for(int u=1;u<=n;u++)
            for(int i=head[u];i!=-1;i=edges[i].next)
        {
            int v=edges[i].to;
            if(low[u]!=low[v])
                degree[low[v]]++;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
            if(degree[i]==1)
            ans++;
        printf("%d\n",(ans+1)/2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/87869903
今日推荐