PAT 甲级 1141 PAT Ranking of Institutions

https://pintia.cn/problem-sets/994805342720868352/problems/994805344222429184

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Scoreis an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int N;
map<string, int> mp;

string lowercase(string c) {
    string ans = "";
    int len = c.length();
    for(int i = 0; i < len; i ++) {
        if(c[i] >= 'A' && c[i] <= 'Z')
            ans += (c[i] + 32);
        else ans += c[i];
    }
    return ans;
}

struct Node{
    int st;
    int num;
    double score = 0;
    string name;
}node[maxn];

bool cmp(const Node &a, const Node &b) {
    if((int)a.score != (int)b.score)
        return (int)a.score > (int)b.score;
    else if((int)a.score == (int)b.score) {
        if(a.num != b.num)
            return a.num < b.num;
        else return a.name < b.name;
    }
}

int main() {
    scanf("%d", &N);
    mp.clear();
    int cnt = 0;
    while(N --) {
        char s[10]; int x; string namee;
        scanf("%s%d", s, &x);
        cin >> namee;

        namee = lowercase(namee);
        if(mp[namee] == 0) {
            cnt ++;
            mp[namee] = cnt;
        }

        node[mp[namee]].num ++;
        node[mp[namee]].name = namee;
        if(s[0] == 'B') node[mp[namee]].score += (2.0 * x / 3);
        else if(s[0] == 'A') node[mp[namee]].score += 1.0 * x;
        else if(s[0] == 'T') node[mp[namee]].score += (3.0 * x / 2);
    }

    sort(node + 1, node + 1 + cnt, cmp);

    cout << cnt << endl;

    node[1].st = 1;
    cout << node[1].st << " " << node[1].name << " " << (int)node[1].score << " " << node[1].num << endl;
    for(int i = 2; i <= cnt; i ++) {
        if((int)node[i].score == (int)node[i - 1].score)
            node[i].st = node[i - 1].st;
        else node[i].st = i;

        cout << node[i].st << " " << node[i].name << " " << (int)node[i].score << " " << node[i].num << endl;
    }
    return 0;
}

  第一次交最后一个测试点没过 要用 double 算 score 然后强制类型转换 (int)

FHFHFH

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/10337546.html