1141 PAT Ranking of Institutions(25 分)

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

几个注意点:

1.将输入的学校名字转换成小写

2.开2个map分别记录学校(字符串)和总分(tws)的映射, 学校和报考人数的映射。

3.分数用double来存,map的映射也用double

4.把tws ns 学校名通过遍历map读入结构体(结构体内tws用int, 读入的时候自动将double换成整数)然后用sort按要求排序

5.输出的时候用个pre记录前面一位的tws 不同就记为i+1

#include<iostream>
#include<string>
#include<map>
#include<algorithm>
#include<fstream>
using namespace std;
const int maxn=100010;

struct node{
	string school;
	int tws, ns;
}ans[maxn];

map<string, double> mp;
map<string, int> mp2;

bool cmp(node a, node b){
    if (a.tws != b.tws)
        return a.tws > b.tws;
    else if (a.ns != b.ns)
        return a.ns < b.ns;
    else
        return a.school < b.school;	
}

string getid(string &s){
	for(int i=0; i<s.length(); i++){
		if(s[i]>='A' && s[i]<='Z'){
			s[i]+=32;
		}
	}
	return s;
}

int main(){
	int n, i=0;
	double score;
	string id, sch;
//	freopen("d://in.txt","r",stdin);
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		cin >> id;
		scanf("%lf", &score);
		if(id[0]=='A'){
			score=score;
		} else if(id[0]=='B'){
			score=score/1.5;
		} else{
			score=score*1.5;
		}
		cin >> sch;
		sch=getid(sch);
		mp[sch]+=score;
		mp2[sch]++;
	}
	for(map<string, double>::iterator it=mp.begin(); it!=mp.end(); it++){
		ans[i].tws=it->second;
		ans[i].school=it->first;
		ans[i].ns=mp2[it->first];
		i++;
	}
	int num=i;
	sort(ans, ans+num, cmp);
    int rank = 0, pres = -1;
    printf("%d\n", num);
    for (i = 0; i < num; i++) {
        if (pres != ans[i].tws) rank = i + 1;
        pres = ans[i].tws;
        printf("%d ", rank);
        cout << ans[i].school;
        printf(" %d %d\n", ans[i].tws, ans[i].ns);
    }
    return 0;	
}

猜你喜欢

转载自blog.csdn.net/Chuyuan_li/article/details/82152902